Boolean Operations

One possibility is to use the andquot;Snap To Rangeandquot; plugin, followed by an andquot;Optimizeandquot; before using the boolean operation. If you are object has tiny gaps between faces, the object collision tests required for boolean operations may fail.


I had some trouble last night with Boolean operations so I thought I would share my understanding of what went wrong.

Maybe someone else has had this problem!

I had a fairly complex object that I wanted to amend and the only seemingly sensible way to do this was by slicing off an entire section (the one I wanted to re-model) and do it again.

I did this by introducing a cube primitive up to the point where I wanted to re-model and cutting away the rest by Boolean subtraction.

This seemed to have worked fine but I ran into all sorts of problems later on – faces not extruding properly and lots of doubled up points. I realise I maybe should have gone about it the hard way and trimmed points / edges but the thought of trimming the best part of 100 edges / points was too much to consider!

What seemed to have happened is that when I cut the part away, lots of stray edges andamp; points had appeared as 3DCP had not known where to put them. When I tried to extrude the newly created face from the subtraction, it went in a completely different direction to that expected. (to the left and up, not straight ‘out’ as would be expected.

I overcame this by carefully trimming away errant edges and points (hard to find these as many were co-located with the real points and edges therefore a case of trial and error). Eventually I was able to perform an extrude operation as I had hoped but there were more problems to come:

When it came to final trimming of points and edges I was getting [what seemed to be] strange errors (andquot;The edge selected is not next to another face, try selecting the points individuallyandquot; or something!). But to the eye, the edge was right next to another face and if you trimmed the points individually, the model lost some of its vital structure.

I eventually overcame this by analysing the exact point positions, discovering to my surprise that they were not lined up (a milimeter out here and there). This was surprising as they had been created by extrude. Surely they should have been co-linear? Anyway, after much shifting they were all lined up and the edges could now be deleted… apart from 1 edge.

The problem with this edge was that there were 2 co-located points – impossible to see, difficult to delete. The only way I could discover where they were was to shift one point to the left and, lo!, there was the extra point. Once trimmed, and the original point reset, the last edge was removed.

I have to admit, I felt as if starting from scratch would have been so much easier!

I hope this is of help to someone… if anyone knows of a better way of ensuring the integrity of the model I’d love to know.


ps – the Object Cleaner never seems to do anything for my models. I know there are co-linear points yet it always reports that 0 edges, 0 points etc were removed? Ideas?

You must be logged in to reply in this thread.

2 posts
recent posts