Paint & Adjust Problems

Hello Richard

After a break from modelling of some time, I am starting a new project for Train Simulator 2017.

Although I have tried to use Crafter on a number of occasions, I have always found it to be unstable so I have continued with Canvas which I have used extensively and I know is very stable. I feel that there are advantages with Crafter so I have taken the opportunity over the holiday to try it again. I tried the latest Beta build first, but had a few problems with that, so went back to 9.3 Build 1620 and this has proved to be much more stable, but still with problems, the main one being associated with the Paint and Adjust operations. In the Beta build, trying to apply a texture with the paint brush or the paint pot invariably crashed the program immediately with a message that I need new drivers for my graphics card. I know it is possible to texture using the UV tools in the Beta version but the paint brush and paint pot operations are useful and need to work properly

In Build 1620, the paint brush and paint pot generally work OK but problems arise at the third paint/adjust operation when the program crashes or if the program does not crash, I find that the textures I had previously applied/adjusted disappeared. Yes again, it is possible to work on the textures using the UV tools, but that is slower than paint/adjust.

I have found a work around, however, that might indicate to you what the underlying fault is. I have found that if the Optimise routine is run at the end of every paint/adjust operation, it is possible to keep going without any problems, but of course, the history of operations is wiped clean so there is no going back.

I think I am happy to move over to Crafter now as my default program, especially as you seem confident of creating an exporter for Train Sim World, but fixing these basic bugs first would be appreciated before trying more ambitious features.

  • This topic was modified 11 months, 2 weeks ago by  acorncomputer.

I’ve not made a textured model in ages (not needed for 3d printing)

When I tried with 9.3 b1649 it just hung on all paint/texturing operations and functions.
Compressing/compacting/optimising made no difference.

The only way I could even colour a part was to edit the material properties.
(Win 7 64 bit)

I am also having a problem with the paint brush and paint pot tools in a new installation in my new high spec PC running Windows 10. As above, the game crashes with a message to update video drivers after using the paint tool on several faces and immediately if the paint pot tool is used either directly from the right panel or from the operations panel. My video drivers are the most up-to date Nvidia drivers for my graphics card. A version I still have on my laptop is still working correctly. Is there a solution for this issue?

You must be logged in to reply in this thread.