New Exporter Problem using RailWorks Editors

Problem Solved!!
Thanks to Paul, I discovered it was user error.
I had placed the environment map in the Specular channel of the material properties.
Once I had clearled the specular channel and placed teh environment map correctly tehre was no problem.
Interesting to note that the old exporter was far more forgiving but gave the wrong effect!!
Steve

REPEAT POSTING FROM UKTRAINSIM.COM
Hi – this one is for Paul I guess but shows up something weird that I’ve found in RW as opposed to RS.
My loco has been textured and uses Environment and Bump Map shaders with Paul’s new 3DC exported and has exported with no problem in RS.
I have transferred all the source files over to RW and re-textured the loco so as to point to the texture files under the RW source folders but have found that when I try to open the basic engine XML file in the RW Asset or Blueprint editor causes the application to crash.
I have tried to pin point the error and have found that texturing with no shader info is OK (ie no bump or environment maps) but as soon as I specify the environment map with the shader TrainSpecEnvMask.fx, then the XML file causes the Blueprint editor to crash. (doesn’t get as far as the export !!)
However, exporting from 3DC with the old exporter does NOT cause the programme to crash with the exact same 3DC settings.

Any ideas Paul?

Thanks
Steve

You must be logged in to reply in this thread.