Alternative Rail Simulator Export

There is a definite bug with the exporter when working in 3DC set to feet – the model is scaled correctly but child groups are positioned wrongly.

If you have no child groups the model will be OK.

I have a fix but will release it in a day or two along with other new features.

I have a feeling that that bug may be part of what I’m having some problem with. I’ve been working with scenery objects as they’re usually a lot less complex. I’ve been getting odd looking shadows when I export them. So I think I’m somewhere along the right track but I’m not sure yet what’s happening.
However, that’s perhaps for another time. The thing that’s concerning me now is that after I export a model, I can no longer make any part not visible. This causes me to have to restart 3DC to continue any work on the model. Any ideas as to what’s causing this?

I had that too – no idea what causes it but after export, 3DC ignores the Visible option for objects.

I’ll have a play around with the export plugin to make sure I clean up any extra objects that get created.

[b:2sud1qq2]New version should fix a few of the bugs

(not the geometry with no vertices one yet – talking to rsdl about that)[/b:2sud1qq2]

Attachment removed – new version later on in this thread….

I’ve done a couple of exports with the new plugin and it seems to be working fine. The only question I have concerns the apparent problem with tall objects have their shadows cut off beyond a certain height. That particular subject doesn’t seem to be covered on this site so I’ll bring it up here. What is the maximum height that seems have a shadow rendered? I was of the impression that objects higher than 20m or 30m were truncated. The pole I modelled was only 40 Feet but it seems to be high enough for the top two crossbar to not show in the preview screen. I was wondering if the exporter is keeping one of the values as metres rather than feet to cause it to truncate or is a 40′ pole too tall to show a full shadow?

There is definitely a problem with shadows but nothing to do with the exporter or 3DC.

Looking at the actual shader code there seems to be a limit on the length of the projected shadow (which depends on the angle of the sun rather than the height of the object.

With the latest exporter you should be able to extend that limit by setting the RailSimX material option to
r0arg0=200
on all shadow objects.

The shader default is 100 but I’ve not had a chance to test this theory.

Hi Paul, I am afraid I am still having the same problem with TSM imported models. I tried a purely made 3DC one and as others report NO problems

Dick

After a day of experimenting, adding one shape at a time exporting and then converting to RS I have discovered that it is only a few shapes that are causing the problem for me. These were easily rebuilt and now the exporter works. Also for one shape at least, importing it singly from TSM got rid of the problem. So far so good.

Thanks Paul

[BLOCKQUOTE class=’ip-ubbcode-quote’][div class=’ip-ubbcode-quote-title’]quote:[/div][div class=’ip-ubbcode-quote-content’]Originally posted by Paul Gausden:

With the latest exporter you should be able to extend that limit by setting the RailSimX material option to
r0arg0=200
on all shadow objects.

The shader default is 100 but I’ve not had a chance to test this theory. [/div][/BLOCKQUOTE]
Thanks for the advice. However, I might not be using it properly as it seems to have no effect. Is it entered just as is in the Custom fields under RailSimX or is there somewhere else it should be entered? I’ve entered it in both the left screen location and in the properties with no apparent effect.

Good to hear you’re back on track Dick <!– s:) –><img src="{SMILIES_PATH}/icon_e_smile.gif" alt=":)" title="Smile" /><!– s:) –>

Bill – looks like there is a bug in the shadowing calculations they are using.
Have you tried making the pole shadow out of two 20′ cylinders on top of eachother?

[BLOCKQUOTE class=’ip-ubbcode-quote’][div class=’ip-ubbcode-quote-title’]quote:[/div][div class=’ip-ubbcode-quote-content’]Originally posted by Paul Gausden:
Bill – looks like there is a bug in the shadowing calculations they are using.
Have you tried making the pole shadow out of two 20′ cylinders on top of eachother? [/div][/BLOCKQUOTE]

Interesting idea…but no joy and it added an artifact again. Going back to the previous model for now.

Erm! Sorry Paul but the TrainBasicObjectDiffuse.fx shader does not appear to be exported with any transparency whereas it did in the older exporter!!!!

Dick

Sorry I should probably have explained that one more clearly.

The old exporter made everything ‘transparent’ which is why translucency didn’t work.

Now if you have transparency in the texture you need to add ‘Transparency’ in the ‘Tx Alpha’ custom material field.

If you’re just using part of the same texture with solid colour this is not needed.

Sorry but itm still does not appear to work. I am doing the loco number set. Two numbers on each texture. One in solid colour surrounded by transparency and the other transparent with solid back ground.

My material settings are:-
60, 20 0, 0, TrainBasicObject…..fx, Trans…, blanc, blank.

Have I got this wrong?

Dick

Hi Dick,

I have just uploaded the 3DC source file for one of my recent wagons as an example.

This has the material options I used for the vehicle numbering (which works OK with transparency)

[img:1atoo7vb]http&#58;//cid-06b528339820717e&#46;skydrive&#46;live&#46;com/self&#46;aspx/Rail%20Simulator/sample%7C_wagon%7C_source&#46;zip[/img:1atoo7vb]
<!– m –><a class="postlink" href="http://cid-06b528339820717e.sk…_wagon%7C_source.zip">http://cid-06b528339820717e.sk…_wagon%7C_source.zip</a><!– m –>

I have also attached another small update to the exporter which tidies up one or two other small bugs so it may be an idea to try exporting again before changing anything.

You must be logged in to reply in this thread.

108 posts