MSTS exported shape crash

FYI – I think MSTS may have a size limit for each group. andnbsp;I had a LOT of parts in one group, and when i tried to run it in MSTS, it crashed with the same error message. andnbsp;I went back into 3DC and moved some of those parts into a different group. andnbsp;Lo and behold, it worked!! andnbsp;Now i just can’t wait to see how many GROUPS MSTS will allow before it crashes andnbsp;;)

I’ve done lots of andquot;hackingandquot; around with a model Terry Thornton gave us for our route (0-6-0 GWR #13)

I’ve done lots of re-modelling on it, re-textured it and chopped off about 600 polys.

Now it fails to load in MSTS with an andquot;unable to load carandquot; message (followed by a crash) before the activity starts.

Other Locos I’ve built work fine – so I don’t think it’s 3DC.

Does anyone have any ideas as to what the problem may be?

Paul

Would also like to add to what Richard has said.
I have found also, that MSTS does not support spaces
in names in the Hierarchy. For example, I have found
on my latest model that this:

Object Group

Does not work, but this will:

ObjectGroup

As Richard has said, sometimes just moving objects around
will correct the problem….

Patrick

It could be that it has exceeded one of the MSTS maximums somewhere.

A thought:

You could try moving like objects to the same group. I try to keep all of the main non-moving andquot;partsandquot; (the parts that define the primary shape of the model) in the Main group. Then I put all small non-moving parts in a single group that is a child of the Main group. I have seen this process andquot;fixandquot; problems like this.

If that doesn’t work you could try deleting one object at a time and seeing if a particular object, or group of objects, causes the problem.

Richard

sounds like one for Richard to advise on! Are you using 5.5? Train Sim Wizard?

From what you describe, it sounds like the s file or maybe one of the ace files has been corrupted – probably the s file seeing as you’ve hacked it so much. Maybe even a face that you have trimmed ‘excess’ points/edges from is now not completely flat – 3D renderers can have problems with this I am told.

I’m only guessing now though. What exactly does the error message say?

Jon

Nope – cleared all the consists….

The loco doesn’t show a thumbnail in the activity consist editor so something is definitely wrong with the shape.

Paul

Sounds like you’ve changed a file name and the consist you are using is still referencing the old name. Or some other similar filename problem – like you say doesn’t sound like 3DCP

Jon

Thanks Patrick, I had already corrected one space in a group – the names of groups are used by the matrices and aminations sections in the shape file and it seems to use white space as the delimiter.

I have found the problem, but not had time to find the solution.

The Wheel animation was causing the error – deleting all animation allowed the loco to export – however adding any new animation caused it to fail again.

When I view the animation in 3DC, it appears to step through the frames rather than smoothly interpolate – I guess I’m doing something wrong.
My other loco has a very smooth wheel/rod animation

I’ll probably get a chance tonight to delete and re-build the wheels from scratch – they came from a library object that was created with an older version of 3DC.

Paul

Paul,

It may be that you have applied an operation while in animation mode. You might want to check your objects to see if any have layers (other than the base layer) in animation mode. This will slow down animation considerably.

Richard

There isn’t a quick way to remove the layers applied in animation mode.

Which bug? The problem where MSTS wouldn’t load your model? It is a mystery to me why MSTS won’t load some models, but I have had very good success with using the grouping technique that I described. And, it works very well with the automated distance levels.

Richard

Well spotted Richard, I must have done a lot of work in animation mode, there were operations everywhere (which explains my missing creasing from another post) – is there a quick way to remove all animation operations?

I removed them all (now I have smooth animation), but the bug was still there – I ended up deleting the wheels and rods and started re-building them from scratch and it seems to be working now.

Thanks to all for the help,

Paul

You must be logged in to reply in this thread.

11 posts
recent posts