8.2.5:Doors anim. is translating cars (resolved)

I have a strange problem (RailWorks2):
The train is made of several cars 3 of which have doors animation.

The doors animation is working properly on each of the 3 cars but, as soon as I hit a key triggering the doors animation, the 3 cars are not in line anymore with the rest of the train (Same effect in asset editor preview.)! The 3 cars are moved to the right (with respect to the train movement).

Each door is independant with its own axis in the door plane.
The animation is OK in 3DCrafter with just the doors being translated along the car length.

The ia file for a given side is created by selecting all the 4 doors from the side and using the export menu.

I’ll send tonight the model and the ia files.

Yes, the ia file and model probably will make it clear what is the cause.

I have to do some work to fix the ia import, so first I’ll get that bug fixed, then I can work on this.

There was definitely something in the animation. I’m just not certain what. I’ll have to think of possible causes.

Did you retry the export of the animation after you had problems?

I made several attempts. I don’t remember what I tried exactly each time.

As mentionned above, the ia file for a given side is created by selecting all the 4 door shapes from the side and using the export menu. I don’t see how this could be done in another way.

I did some more investigating. The file had animation information for the "Main" group, which does have animation information in the file sent to me. I’ll try exporting using the method you used and see what I get.

I have found the bug. Now it’s just a matter of fixing it.

I have it fixed.


Is it possible that you send a new ia file (animation on one side) to make sure it’s OK in RW2?

(update: I wondering what makes the door animation so special? I exported many animations for cab animation and for pantograph animation. They all worked OK.)

That particular model had animation on the "root" (coach), and that was included because the doors were not in the same sub-hierarchy. If they had been in the same sub-hierarchy, there wouldn’t have been a problem.

I confirmed it is now correct by importing the animation back into 3DC.

I’ll reply to your email with one of my exports, but I’ll be releasing in a matter of a few minutes, so maybe it isn’t of much use.

You must be logged in to reply in this thread.

10 posts
recent posts