3DCrafter 9.1.1 Build 1264 Available

3DCrafter 9.1.1 Build 1264 is now available for download: Download 3DCrafter 9.1.1 Build 1264[/url:171c6wge]

This version is specifically for those users who have had problems installing 3DCrafter. There are no bug fixes or new features.

The installer for this version was prepared on a 64 bit Windows 7 and has been tested on both 64 bit and 32 bit versions of Windows 7.

Unfortunately, the new version still gives me the same errors – i.e. If I run as administrator, the splash screen appears and freezes with the 392 error and if I run it normally, no splash screen appears and I get the 91 error. I deleted all references to 3D Crafter 9 and 9.1, cleaned out the registry and re-installed, but again, no joy.

I have version 8.2 working on my PC. Could this be causing a problem?


P.S. I have discovered something strange. When I try to uninstall the program, although I receive a message that the program has uninstalled, in fact, the folder and all of the files are still there.

P.P.S Even stranger, after I deleted the folder, I decided to install an older version of 3D Crafter 9 – version 9.0 (build 1063) and it worked with no problems. So something seems to have changed between the two versions. I also discovered that this version can be uninstalled normally. With further experimentation, I discovered that the program that I normally use to uninstall unwanted programs – Revo Uninstaller – does not list version 9.1.1 in its list of programs, but does list version 9.0.

Instalation executes fine as did the earlier version, but, once I try to run the program I still get the error #91. The exact error says… "Run time error #91 Object variable or with block variable not set."

Uninstalation went without a hitch.

Thanks for looking into this. I’m sure you will figure this one out.


Its been very quiet so far this month, but I was wondering if any progress is being made on resolving the issue that is causing problems installing 3DC 9.1 in systems with Windows7 (64). AS I mentioned above, I can get version 9(Pro) working but woulld like to see the additional improvements introduced in varsion 9.1.


I’ve thought on this one. I haven’t come up with anything brilliant.

I’m wondering if many/any people have 3DCrafter 9 that doesn’t work, but have 3DCrafter 8 that does work, on the same computer. This would likely indicate a possible cause since 3DCrafter 9 and 8 are very similar in which parts of Windows they use.

Actually, as far as I know they use exactly the same parts of Windows. If so, then that seems to indicate that 3DCrafter 9 should work without a hitch alongside 3DCrafter 8.

And, if version 9 works, but not version 9.1, that is very strange.

Just to confirm that I have 3D Crafter 8.2.8 (Build 1144) and 3d Crafter 9 (Build 1063) working. They can work simultaneously. I have uninstalled 3D 9 and tried to install 9.1, but continue to get one or other of the two error messages mentioned above (depending on whether I launch it normally or as administrator).


Ok, so then it’s just a matter of determining what’s new in 9.1 vs 9.0. I don’t recall anything that might cause something like this. But, I’ll look through things thoroughly.

I don’t see any significant differences. I wonder now if it is a registry issue of some sort. 9.1 uses the same registry entries as 9.0. I have a "9.2", which doesn’t actually work, but uses different registry entries. It would be interesting to see if it runs on computers that can’t run 9.1. I’ll see what I can do about putting together a semi-working version, for testing purposes.

You must be logged in to reply in this thread.

8 posts
recent posts