3DC 9.1: Draw points not showing all points (resolved)

Please see attached model.

I can confirm this problem.

I noticed that I have "special" code for ATI graphics chips for rendering points. Is this an ATI graphics chip you have in your system?

Could someone else who doesn’t have ATI graphics that can try the file attached to see if points render correctly for them? Thanks.

I have this fixed. I’m 90+% certain this is a bug in the ATI drivers, but I’d love it if someone who has a non-ATI card to try this to see if they have the same problem.

I have computers with ATI and Nvidia cards. Both show the problem w/ 3DC 9.1.

You’ve tried it on both, with the attached model?

OK. Back to the drawing board. I have a fix, but only for ATI based cards. I really wish I had a NVIDIA based system right now, because there are other things I’d like to check.

Here is an example with the model I just sent to you.
It seems that no points are drawn (W7 64bit; GTX470 + driver 8.17.12.7061 (also named 270.61)).

Can you do me a favour and load the model you have attached to this thread with a NVIDIA based computer, zoom in like in the attached picture, so I can see what the differences are? Thanks.

I have now the same number of drawn points with my Nvidia card.
However, as you see in the above post there are still cases with points not displayed.

(I’ve updated my post as it may not be clear about what "is the same").

Yes, agreed. It still doesn’t work correctly with the model you sent to me. I’m investigating.

The cause of the problem was related to shapes with unused points. An "optimize" will cure the problem for a shape. I have a fix for the next release. I also changed the defaults of the "optimize" operation because it was overly aggressive welding points.

You must be logged in to reply in this thread.

11 posts
recent posts