V6 Rel2 unrecoverable error #91

pwillard,

I have been able to reproduce the error 91 (and error 9) as you described using Paul’s Cabmaker plug-in. To be honest it looks as though a material is being applied in the wrong order in the plug-in and that is causing the undo/redo crashing. But I can’t be sure until I see and play with Paul’s plug-in. I haven’t been able to reproduce the error in any other way. At least not with my current version (revision 4).

Paul,

Can you send me the source for your plug-in so I can see if my speculation is correct (see above)

Richard

Hi Richard,

I finally got around to installing V6, going with Rel2 that I downloaded Sunday. Installation went ok (Win XP residing on drive F: andnbsp;) I have V5.7 still installed.

Opened a model I am currently working on (a safe copy of it, that is) and it converted it to v6 and looked OK.

I added a cube primitive, scaled it to the required size, and positioned it using the properties. The selection tool seemed a bit sluggish, and had to wait for things to catch up. Likewise with the face selection tool.

I used decapod’s axis shift tool to centre the axis on one face of the cube to aid in accurate positioning.

Then, I selected the bottom face of the cube and pressed the ‘delete’ key. Bang – unrecoverable error #91. I repeated this with the same results.

For something this trivial, I assume I have done something wrong. Should I have installed earlier versions of v6 first? I did search the forums for #91 but nothing showed up.

Ian

The model is on its way to you now andnbsp;:)

Sorry Ian I still can’t reproduce the problem even with the model you provided.

What I was able to reproduce was the sluggishness you mentioned with Rev 2 . I tried it with Rev 3 and the sluggishness is gone.

Richard

I can’t reproduce the cube primitive problem you mentioned. Can you send me the model (<!– e –><a href="mailto:support@amabilis.com">support@amabilis.com</a><!– e –>)?

The face selection tool is a bit sluggish in rev 2. It will be back to normal in rev 3.

Richard

I’ve just tried this on my machine (win me, gforce4, only v6 rev3 installed) with no problem.
(if I am following this right…. started 3dc, added a cube, rotated (with middle mouse button) so I could see the bottom face, face selected the bottom face, pressed the del. key (on keyboard), face disappeared (as expected), no errors…..)

Anyone else not able to do this ?

Thanks, I’ll try Rel 3 tonight.

Just installed 6.003, no upgrades, and didn’t have any problem doing this.

Rel 3 downloaded, Rel 2 uninstalled and Rel 3 installed.

This time, no model, just grabbed a cube primitive, selected the bottom face (less sluggish this time) and then Delete.

Same error #91.

Uninstalled rel 3 and unistalled v5.7 and then installed just Rel 3. Same result.

Uninstalled Rel 3, reinstalled v5.7 and it is still working fine. andnbsp;:(

Is there any other information that might help you figure out what is happening?

I’ve tried it on 3 computers including one older 200Mhz Windows Me machine without any problems.

I’m not sure what to suggest andnbsp;??? andnbsp;I’ll have to think about it.

Richard

What is error #91? Maybe I can do something about it this end.

Since reverting to v5.7 it has been mostly fine, except once, when exporting to MSTS, I got a #91 error. I tried again, and it was fine, and has been so ever since.

I would so like to move up to v6 though.

Error 91 is something like andquot;object not initializedandquot; or something similar. It can happen in all sorts of ways. I doubt there is anything that you can do (short of sending me your computer).

One person who was having this trouble tried this and it was successful: [img:yrm5a885]http&#58;//www&#46;microsoft&#46;com/downloads/details&#46;aspx?FamilyID=8f0a8df6-4a21-4b43-bf53-14332ef092c9andamp;DisplayLang=en[/img:yrm5a885]
<!– m –><a class="postlink" href="http://www.microsoft.com/downloads/details.aspx?FamilyID=8f0a8df6-4a21-4b43-bf53-14332ef092c9andamp;DisplayLang=en">http://www.microsoft.com/downloads/deta … layLang=en</a><!– m –>

I’m not so sure it will work for you since you are running XP. But it is probably worth a try.

Richard

In rel 3, i’ve been getting this error a lot.

The way I can nearly always get it is..

1) Use Pauls Cabmaker (the new one)
I then Shift Center, Shift Points, Shift some more points… select undo BANG! error 91.

I get this error too (with release 3). It seems to be connected with Undo or Redo operations. I also get it sometimes when I click inadverteldy in some empty space in one of the view-windows. No big problem though!

Yes Paul,

I’m pretty much stuck on multiviews so I always have the X,Y and Z viewports open too.

(I wasn’t trying to trash on your cabmaker, btw.) I Love it.

It was just a reproduceable if I used the plugin. andnbsp;It’s probably unrelated.

You must be logged in to reply in this thread.

19 posts
recent posts