v10 Beta 2 Available

v10 Beta 2 is now available.

IMPORTANT: it looks like uninstall/reinstall is required. I’m still trying to understand why. Remember to uninstall any “3dc prerequisites” in the install list also Sorry!

Download 3DCrafter 10 Beta 2

With version 10, 3DCrafter now has a “ribbon” interface. You might know it from Microsoft Office, WordPad, Paint and others. I won’t try to explain it. I hope everyone has used it at some point. One of the benefits of this interface, and the reason I decided to use it, is context specific tabs that show only functions related to your current selection. I think this works particularly well with 3DCrafter.

IMPORTANT: This version is feature complete, but there are still many features that need refining, and there may be some that simply do not work, or don’t work as expected.

What’s new
========

o) I have organized the main toolbar, the “ribbon” by modelling phase: “Build”, “Paint”, “Layout” and “Animate”. Each of these phases has a toolset associated with it. There’s a toolset button on the left side of the ribbon.

o) There are three user modes available: “Novice”, “Intermediate” and “Expert”. These are available on the “Options” tab. Novice is really just for beginners. It hides many features so that beginners are not overwhelmed. I expect most people will want to use Intermediate, which has all features enabled. Expert is for those who want to work more like 3DCrafter version 9. It combines the Build, Paint and Layout phases into one. Unfortunately this results in a crowded toolset, but I’ll be working to improve that.

o) The Navigation Controls is gone. Gone forever. It was more trouble than it was worth. People tended to get lost, get things turned upside down etc. It has been replaced by “Orbit”, “Pan”, and “Zoom”. These are on the main toolbar, but they can also be accesssed via the center mouse wheel/button. Orbit is the center button, Pan is the shift key held down with the center mouse button, and Zoom is the scroll wheel.

o) The Edit Control is now “compact”. It is basically the same thing, but making it “compact” makes the various surfaces easier to click on because I can orient things more suitably. The one thing you’ll notice is that the vertical scale/move are gone. But, all you have to do is right-click on the surfaces to get vertical scale/move. Just like if you were clicking on an object to move it up and down. I want to get rid of the Edit Control completely at some point, but there are really too many things to do, and I want to put out something as a starting point.

o) The biggest new “feature” is the ability to draw primitives. How it works:

-pick a primitive,
-click to start, drag, (use the scroll wheel to get the detail level you want)
-click to indicate the size you want
-drag again for height (use the scroll wheel to get the vertical detail level you want)
-click to finish

o) with v10 context is everything. You should only get functions that are related to the modelling phase you are in, and what (if anything) you have selected. This will have to be progressively refined through the alpha/beta period.

o) One of the goals is to make it so that normal modelling tasks can be completed without ANY toolbars, panels etc visible, AND without having to remember any complicated key-combinations. I’m still working on this one, but it’s coming along. The key is that the ribbon can be minimized and important tools and operations can be placed in an are called the “Quick Access Toolbar”. I’m going to need help in choosing the standard tools and operations to add to it. Select, Select Point/Edge/Face, and Extrude are obvious ones I’d say. But there are certainly others.

o) The panels that normally were located along the left side now have to be shown using the View tab. Only those panels that are relevant to the toolset you are using are available. During modelling I don’t think any of them need to be displayed normally. Just every once in a while. I imagine it like this: model… model… model… need to look at the layers – show the panel – do something with layers – hide it … model… model… model… need an oddball operation not on a context tab-show the panel use the operation-close it… model… model… model…. When in Paint mode I kind of think it is the same. You choose a material, and then close up the material panel. But that might not always be the case.

o) The settings for an operation (if any) are immediately shown after you apply it to a selection because this is typically when you need them. I’ve tried to make it so that it doesn’t get in the way, but sometimes it does. It isn’t moveable, or closeable. I’d rather it not be. My experience with closing these tool settings is that they always seem to be gone when you need them-and operations almost always need some adjustment to settings. My experience with moving them is that they just end up in the way again in a couple of minutes, so they are constantly being moved and in the way. The way I have done it they are consistent, and it really isn’t that hard to ctrl-center click to pan the scene if something is obscured. That’s just my opinion of course, not everyone is going to agree.

o) The “Info” panel on the right is now context specific also. I “hope” it can always be closed during modelling unless doing a tutorial. I’ll need feedback on this. The panel can be closed either by clicking on the divider, or dragging it to the right. It can be re-opened by clicking on the divider or dragging it to the left.

o) There is a simple “material palette” on the paint/expert toolsets.

To do
====
o) Icons need to be completed
o) A couple of tutorials need to be entirely re-written, and many others need adaptation. Many screen shots need updating. I’m leaving that to the very end. I want ot be 100% certain the interface won’t change. It’s a big job and I don’t want to do it twice.
o) There may be paint tool options coming, and a new improved edit control. But I’m still deciding on them. They may be in v10.1

BUGS: Any bugs you find, please report them here, even if you have reported them before. If they aren’t fixed yet, it means that I missed them.

Only had a chance to have a quick play so far but I notice the draw shapes tool only lets me draw a cube, no other options – sphere, cylinder etc are shown.

V10 installed and ran fine (vista 64 bit) once I had deleted all traces of the previous beta.

Paul

Hi Richard,

So far my scripts and custom operations seem to work OK with beta 2

Standard plugins I can’t get to appear on the menu at the moment, must be just missing something, I’ll keep working on it.

Import/Export plugins – I have an alternative STL plugin for shapeways (text format with different orientation). When I select that as the filetype to export, it always uses your built in STL file exporter (binary)
Changing the type to STLX lets me use my exporter.

Is the final version going to remember the screen settings between sessions?

Looking pretty good so far.

Cheers,
Paul

Hi Richard – yep, same for me, no other shapes.

Plus a slight display anomaly when I have operations turned on:

Turning layers on and off fixes the display bug….

My custom plugins do appear in the Options list of plugins and are enabled… They just don’t appear in the plugins menu.

  • This reply was modified 3 years, 1 month ago by  PaulGausden.

Seems to be a problem when switching between cameras.

If I add a cube then switch to the animation camera the display update seems to be pretty slow but right click and try to go back to layout camera and I get:

View post on imgur.com

Thanks guys. I should be able to get updates out fairly quickly now, without having to re-install. At least I hope so.

PaulGausden,

3DCrafter asks plugins “Do you support this?” with the Plugin_GetValidation method. So, basically, you need to respond appropriately.

Here’s an example for a plugin that supports multiple shapes:

If ComponentType = CSGEShape _
And SelectionType = CSGSelectShape Then
ValidMinComponents = 1
ValidMaxComponents = 999
Else
ValidMinComponents = -1
ValidMaxComponents = -1
End If

Here’s one that supports multiple edges, not necessarily only on one shape:

If ComponentType = CSGEShape _
And SelectionType = CSGSelectEdge Then
ValidMinComponents = 1
ValidMaxComponents = 999 ‘999+ means any number
ValidMinShapeSubSelection = 1
ValidMaxShapeSubSelection = 999 ‘999+ means any number
Else
ValidMinComponents = -1
ValidMaxComponents = -1
End If

I “think” that if it is “edge”, you may need to say “2” if only one edge is supported (for the two faces it shares), but I’d have to check on that.

I have to admit that I forget the rules exactly. I “believe” they are fairly straight forward. I have to update many plugins that aren’t right.

I’ve been humming and hawing about that edit control of mine. I had it in mind to remove it, but quite honestly, with 3DC’s auto-switch from selecting to doing (meaning you can just grab something and go without changing tools), it makes sense to keep it. BUT I think I’d like to make it a little simpler, and behave slightly differently.

First, I don’t see any reason to use it to move things around. The select tool is also the move tool. So, perhaps it should simply be Scale, Rotate X, Rotate Y, Rotate Z. BUT I think the scale should be changed to scale only in two directions. This will fit well with the upcoming changes to snapping, and just generally make snapping work MUCH better. You just need to line up two edges by moving the shape (with those two edges snapping into place), and then the scale keeps those two edges as they are, and snaps the other two edges while scaling.

Second, I think I should reorient it much like it is in the orthographic views. It never lines up with the selection properly anyhow, so why bother trying to fake it, I’d say. AND it makes it easier to place it near the selected shapes without it looking strange. Close, but not in the way would be ideal, I’d say. Just generally I want to keep buttons close to the mouse. (Btw, I’m looking at a context toolbar that will come up via right-click, but I’m not 100% sure I can do it quite yet. Need to experiment)

Anyone have any thoughts on this one?

Hi Richard,

Some progress with plugins. Where there is a selection, I can get the plugin to appear.

However my step builder plugin has no selection criteria and doesn’t appear anywhere in the plugins menu, just the options plugins list.
It should probably appear all the time, whether there is anything selected or not.
A bit like your create face plugin – but that disappears when something is selected.

One new “bug” I’ve seen now – Can’t use hierarchy view to drag groups around. I use that a lot with my models.

I like the idea of an orthographic edit control – sounds good to me.

Cheers,
Paul

  • This reply was modified 3 years, 1 month ago by  PaulGausden.
  • This reply was modified 3 years, 1 month ago by  PaulGausden.

Hi Richard

Downloaded and installed OK. Had to enter my key again – it took several ‘goes’ to successfully enter it. (Closing and re-opening the first few times after entering the key still brought up the ‘Free’ version).

No shortcut automatically created, so had to burrow into the Users/…Apps/ folder to locate the ‘exe’ file to create one.

Noted that initial screen no longer indicated either ‘free’ or ‘pro’ version, nor indicated the loading process.

As mentioned by others, only the cube shape can be drawn – the other primitives do not appear.

Is there a way to extend the ‘layers’ panel to view more than three layers at a time? I found that with an object on which a lot of operations have been done that it is tricky to locate and return to a particular operation to rectify an error.

But my biggest problems are with the UV mapping. It is still not possible to zoom in in any of the UV mapping windows. V9.3 has this possibility which is almost essential when mapping details in a texture. Clicking the ‘Remember these settings’ flag in the material panel (e.g. when I have changed the default setting of 2 to 0.5 in the ‘Tile by Unit’ box) results in a runtime error. When I attempted to recover the object on re-start, all of the previous mapping information was missing. On one occasion, the object I was working on (fortunately only a test object) was not successfully recovered.

The ‘back face’ operation and plug-in do not appear. Do these need to be registered separately as I seem to remember was the case in an earlier version of the program.

But on the positive side, all of the operations and plug-ins I used in the ‘build’ phase seem to work normally.

BFM

Download beta 2.

Problems
1: cannot import obj format models
2:.my serial code does not work as says invalid
3. Their is no Export
4. Uv re-texturing fails to work

oh main last thing my previous v9 3d crafter just crashes all the time

spudnick, I’ll check into that serial code issue today and get back to you via email.

spudnick, I couldn’t find your order. Can you contact me about it: “assistance at amabilis.com”. Thanks.

I’ll be putting out frequent updates. As I do I’ll list what has been fixed. So far today:

o) Fixed problem with missing draw-primitives
o) Splash Screen displays version and progress
o) Corrected a problem with how plug-ins are sorted by context
o) Fixed inability to move components in hierarchy
o) Changed edit control to be consistent between perspective and orthographic views (I don’t LOVE it, but better IMO)
o) Fixed anomalies in panel displays (there may be some I missed)

Outstanding:
o) saving/restoring of view settings between sessions
o) can’t reproduce issue with animation/layout cameras switch causing crash
o) issue with serial number not being accepted
o) shortcut on start menu sometimes not being created
o) UV related operations zoom not working
o) Tile by unit crash
o) File recovery issues.

Let me know if I missed anything. I’m trying to get everything but I might miss something.

PaulGausden:

This is what you need I think to show a particular plugin always (and the new version I just posted):

ValidMinComponents = 0
ValidMaxComponents = 999
ValidMinShapeSubSelection = 0
ValidMaxShapeSubSelection = 999

BFG:

There are +/- buttons on the layers panel to increase/decrease the number of layers displayed. They may not have worked or have been visible in the initial Beta 2, but I think they work now.

The back-face operation isn’t one of mine. PaulGausden’s perhaps?

BFG 🙂 🙂 – You’re thinking Roald Dahl Richard!

Plugins now behaving as expected. My plugin now appears all the time.
You’ve done the same for the bridge engineer but you might want to change the Foundry and create face plugins to be the same.

The back face operation is one of mine – I should have an installer out in the next few days.

The thread ‘v10 Beta 2 Available’ is closed to new replies.