v10 Alpha 2

v10 Alpha 2 is now available.

If you installed Alpha 1 unfortunately you will have uninstall it, and also the 3DCrafter Prerequisites.

Download 3DCrafter 10 Alpha 2

With version 10, 3DCrafter now has a “ribbon” interface. You might know it from Microsoft Office, WordPad, Paint and others. I won’t try to explain it. I hope everyone has used it at some point. One of the benefits of this interface, and the reason I decided to use it, is context specific tabs that show only functions related to your current selection. I think this works particularly well with 3DCrafter.

IMPORTANT: This version is still very much incomplete. I have “roughed in” many features just so that the general work-flow can be evaluated. A fully functional beta is expected in about a week.

What’s new

o) I have organized the main toolbar, the “ribbon” by modelling phase: “Build”, “Paint”, “Layout” and “Animate”. Each of these phases has a toolset associated with it. There’s a toolset button on the left side of the ribbon.

o) There are three user modes available: “Novice”, “Intermediate” and “Expert”. These are available on the “Options” tab. Novice is really just for beginners. It hides many features so that beginners are not overwhelmed. I expect most people will want to use Intermediate, which has all features enabled. Expert is for those who want to work more like 3DCrafter version 9. It combines the Build, Paint and Layout phases into one. Unfortunately this results in a crowded toolset, but I’ll be working to improve that.

o) The Navigation Controls is gone. Gone forever. It was more trouble than it was worth. People tended to get lost, get things turned upside down etc. It has been replaced by “Orbit”, “Pan”, and “Zoom”. These are on the main toolbar, but they can also be accesssed via the center mouse wheel/button. Orbit is the center button, Pan is the shift key held down with the center mouse button, and Zoom is the scroll wheel.

o) The Edit Control is now “compact”. It is basically the same thing, but making it “compact” makes the various surfaces easier to click on because I can orient things more suitably. The one thing you’ll notice is that the vertical scale/move are gone. But, all you have to do is right-click on the surfaces to get vertical scale/move. Just like if you were clicking on an object to move it up and down. I want to get rid of the Edit Control completely at some point, but there are really too many things to do, and I want to put out something as a starting point.

o) The biggest new “feature” is the ability to draw primitives. How it works:

-pick a primitive,
-click to start, drag, (use the scroll wheel to get the detail level you want)
-click to indicate the size you want
-drag again for height (use the scroll wheel to get the vertical detail level you want)
-click to finish

o) with v10 context is everything. You should only get functions that are related to the modelling phase you are in, and what (if anything) you have selected. This will have to be progressively refined through the alpha/beta period.

o) One of the goals is to make it so that normal modelling tasks can be completed without ANY toolbars, panels etc visible, AND without having to remember any complicated key-combinations. I’m still working on this one, but it’s coming along. The key is that the ribbon can be minimized and important tools and operations can be placed in an are called the “Quick Access Toolbar”. I’m going to need help in choosing the standard tools and operations to add to it. Select, Select Point/Edge/Face, and Extrude are obvious ones I’d say. But there are certainly others.

o) The panels that normally were located along the left side now have to be shown using the View tab. Only those panels that are relevant to the toolset you are using are available. During modelling I don’t think any of them need to be displayed normally. Just every once in a while. I imagine it like this: model… model… model… need to look at the layers – show the panel – do something with layers – hide it … model… model… model… need an oddball operation not on a context tab-show the panel use the operation-close it… model… model… model…. When in Paint mode I kind of think it is the same. You choose a material, and then close up the material panel. But that might not always be the case.

o) The settings for an operation (if any) are immediately shown after you apply it to a selection because this is typically when you need them. I’ve tried to make it so that it doesn’t get in the way, but sometimes it does. It isn’t moveable, or closeable. I’d rather it not be. My experience with closing these tool settings is that they always seem to be gone when you need them-and operations almost always need some adjustment to settings. My experience with moving them is that they just end up in the way again in a couple of minutes, so they are constantly being moved and in the way. The way I have done it they are consistent, and it really isn’t that hard to ctrl-center click to pan the scene if something is obscured. That’s just my opinion of course, not everyone is going to agree.

o) The “Info” panel on the right is now context specific also. I “hope” it can always be closed during modelling unless doing a tutorial. I’ll need feedback on this. The panel can be closed either by clicking on the divider, or dragging it to the right. It can be re-opened by clicking on the divider or dragging it to the left.

o) There is a simple “material palette” on the paint/expert toolsets.

To do
o) Icons need to be completed
o) The expert build toolset is really crowded. I don’t know what I’ll do about that yet. Probably I will buttons auto-size small on some monitors so it fits in.
o) Many functions are there just as buttons and don’t do anything.
o) The right-click menu only sort of works, and hasn’t been modified for the new context based interface. I may move some of the features to the ribbon. I haven’t decided for certain.
o) A couple of tutorials need to be entirely re-written, and many others need adaptation. Many screen shots need updating. I’m leaving that to the very end. I want ot be 100% certain the interface won’t change. It’s a big job and I don’t want to do it twice.

What’s coming

o) along with the simplified material palette, I’m going to make the “fill” tool apply using a kind of “automated unwrap” based on the auto-unwrap plug-in. It’s not perfect, but for simple models it works pretty well when combined with the paint tool. Of course more advanced material application is still possible via various operations. Actually… I’m still working on how I’ll be doing this.

I’m not sure what else needs to be said other than v10 is very much still a work in progress.

I hope to be putting out updates nearly daily from now until the official release. Updates are automatic, all you need to say is “yes” when asked.

There’s no need report bugs at this point unless they cause a crash. There are plenty of things not done, semi-done, not working etc, and I think I’m aware of them.

Feedback is much appreciated. A lot of changes were made based on feedback on Alpha 1. I’m still open to suggestions on the interface, though I can’t promise anything.

Hi Richard, first attempt, immediately after installing…

Win 7 64 bit.

I’ll try in Win 10 next…

  • This reply was modified 2 years, 4 months ago by  PaulGausden.

Did you uninstall first? Both 3DC entries in the list.

The “Thread Exception” message is temporary, btw. It should just crash and stay crashed.

I had the same thing happen before I uninstalled everything and re-installed. That cured it for me.

Error for me too…
Win10pro 64bit
I can’t post an image, but error is “Unhandled Exception” without other specifications.

Uninstalled and reinstalled? Both 3DC and the prerequisites?

Doh! – forgot to uninstall that time….

but uninstalled on windows 10 and got the same problem after install.
Unhandled thread exception, followed by thread exceptions (lots)


I have not unistalled v9.3…

Ok, that’s wierd. Gonna have to experiment to see if I can reproduce it.


Got it working – remove prerequisites and anything that said 3D crafter from the programs list… time to play

  • This reply was modified 2 years, 4 months ago by  PaulGausden.

Yes, that was critical. Prerequisites.

OK for me too, thanks.

Is it possible to enter the code of the new license?

Yes, on the file menu.

I tried entering the up-grade key but pressing ‘ok’ stalled the program after a message saying that ‘the account server is unavailable, please try later’. Message then appeared that 3DCrafter has stopped working. Is the Alpha 2 version not intended to be upgradable?

Otherwise, fairly simple operations worked smoothly. I can see from the 3DCrater 10 folder that all the plug-ins and some of the scripts are there. How are they accessed with the new interface?


Correction to above. I have been able to enter the up-grade key and see that the plug-ins and scripts are now visible. Only issue now – not a huge one – is that the program crashes on exit after save.


The thread ‘v10 Alpha 2’ is closed to new replies.

18 posts Thread is closed for discussion