TrainGlassWeatherEffects.fx Not Working in 3DC9.3?

I have used this shader successfully in 3DC7 & 8 but when i try to use it in 9.3 then I don’t get the effect or anything like it.
In fact the window is just a back, just about see through effect.
I have tried importing a window object that worked in previous versions into the model but after exporting, then I get the effect above.
I am concluding it is a 3DC issue because I have followed my own routine but a full tutorial on this and get the same effect.

Has anyone made a window with this shader in the 3DC 9.3 version and managed to get it to work?

Thanks

Steve

I haven’t had any other reports of this problem.

Anyone else know? (bumping this post hoping someone might know)

Richard
I have found the problem and it seems to go back a few years when this shader first came out.
The problem seems that the export does not put the custom material value of “weatherglass_1” into the material section and simply inserts the next material code of “materialxxx”
Paul Gausden fixed this in his alternate IGS exporter but I haven’t used this now so finding the problem still exists. There were quite a few posts back then under Rain Effects if you search back
I can send you the culprit code if you want??

You have to modify the TrainGlassWeatherEffects.fx area in the GeoPcDx file as below.

<ShaderName d:type=”cDeltaString”>TrainGlassWeatherEffects.fx</ShaderName>
<TextureByName>
<e d:type=”cDeltaString”>textures\[00]windiff_nm</e>
<e d:type=”cDeltaString”>textures\[00]windiff_nm</e>
<e d:type=”cDeltaString”>textures\[00]winnorm_nm</e>
<e d:type=”cDeltaString”>textures\[00]windiff_nm</e>
</TextureByName>
<Name d:type=”cDeltaString”>weatherglass_1</Name>





<MipLodBias>
<e d:type=”sFloat32″ d:alt_encoding=”00000000000000C0″ d:precision=”string”>-2.0000</e>
<e d:type=”sFloat32″ d:alt_encoding=”00000000000000C0″ d:precision=”string”>-2.0000</e>
<e d:type=”sFloat32″ d:alt_encoding=”000000000000F0BF” d:precision=”string”>-1.0000</e>
<e d:type=”sFloat32″ d:alt_encoding=”0000000000000000″ d:precision=”string”>0.0000</e>
</MipLodBias>

Wiper pairs needs to be set with

RailVehicles\Passenger\LNERGRESTeak\Textures\winwmotion_nm.ace
RailVehicles\Passenger\LNERGRESTeak\Textures\winnorm_nm.ace

I’ll move this to the “Bugs and Glitches Forum” so it doesn’t get missed.

You must be logged in to reply in this thread.

Not Resolved
5 posts