Surface Object Builder cross-section views

You could be correct the Surface Object Builder is the only to utilize all three views other than the main. If you rotate the images especially for the Surface Builder then you have to rotate that surface once it is saved to the main window. Switching the front and side images in the Surface Builder is a better solution because it requires no rotation upon import back to the main program.


Hello, I’m new to the forum and I’m enjoying 3DC. However I believe I have discovered an incosistancy in the cross-section image buttons. I have made front, side and top cross-sections. They line up nice in the main window and any objects created there are in the correct aspect. However, using the same three images in the Surface Object Builder tool results in the created object being 90 deg. off with respect to the top view. I can over come this by inserting the top picture in the side view and the side in the top or by making a second top view image turned 90 deg. It is really just an inconvenience, especially if your trying to make models on a tight time constraint. Well thanks for your time. Let me know if you need more info.

I had a look and for the life of me I can’t see anything wrong.

Can you attach an image that shows the problem?


Sure, here they are

Main screen
Notice the top of the plane faces down and the front view is the top right, side bottom right. When I draw a surface in the scene and align it wit the cockpit all is well.

Image removed see images below

Surface object builder
Notice the same three images. The surface again lines in the front and side, but not the top.

Image removed see images below

I know what your saying ‘He put the wrong image in the wrong view’, not so. In the surface object builder the front view is on the bottom right and the side on the top. If you want I can post images with one view turned off. To correct I just put the front view in the side and vice versa. Hope this helps.

I don’t see the problem. The only difference I see is that the Surface tool has the views arranged differently.

Am I missing something?


All that is really wrong is that the buttons on the Surface Object Builder Tool are labeled incorrectly. Following the labels to insert the images results in the surface being rotated 90 degrees on the top view making it impossible to surface the images correctly. Note the change in aspect of the surface in the top view from the first to second image. Wrapping the surface around the cockpit in the front view section results in the surface wraping horizontally along the wing in the top view. As shown in the following screenshot.

It its really not a problem on my end as I just switch the side and front image. It’s just something I wanted to point out that I myself first thought was me.

Thanks again

By the way this program is the best I’ve used, and I’ve tried most. <!– s:) –><img src="{SMILIES_PATH}/icon_e_smile.gif" alt=":)" title="Smile" /><!– s:) –> Makes models fast and accurate. Thanks for making such a great affordable program.

Here is the exact same images and the same process done from the main window using a face.


If I put the side view image in the front view window and the front view image in the side view window, I get the following result.


Sorry about the giant images just don’t want to lose the resolution.

Finally figured it out. It think!

IMO, the Surface Builder is actually correct and the main modeller is wrong. (correct me if I am wrong) The object is supposed to be oriented as shown on the icons for the views. If you do that the Surface Builder works and the main modeller doesn’t.

All you need do is rotate your top view image by -90 and your side view image by 180 degrees and it should work in the Surface Builder. You probably will want to have two versions of the top view image. One for the main modeller and one for the surface builder.

PS Glad to hear that you are liking 3DC.

You must be logged in to reply in this thread.