Exporting Groups to Railworks

I would be grateful for any advice with a problem I have exporting a steam locomotive from 3D Crafter to Railworks. My issue happens when I add a new group to the existing hierarchy for the locomotive. As can be seen from the screenshot from Crafter, the hierarchy currently comprises nine child groups under Main. These are the animated groups for the main moving parts. I have no problem exporting this to Railworks and the loco appears normally in the game (Screenshot 2) and it can be picked and driven (see the first screenshot). All of the animations I have done are working. My problem happens when I add a new group to the hierarchy. The tenth group causes all of the groups not to appear after export to Railworks, even if that group is nested as a child of an existing group. It does not matter what the object in the group consists of – I tried adding a group consisting of a basic cube – any additional group causes all the other groups to disappear. The loco still exports to Railworks – it can still be picked and driven, but no moving parts (Screenshot 3). If I remove the additional group, all the moving parts become visible again. No changes were made to either the bogey or engine blueprints. I am baffled by this issue and would be glad to know if anyone else using 3D Crafter has had a similar experience, or any advice on how to resolve it. I still have to animate the Union Link, the Combination Lever and the Valve Stem and thus need to add at least six more groups (two for each side of the loco) but I am stymied until I find a solution to this issue.

As I am unable to show screensshots here, I am posting a link to the 3D Crafter topic in UKTrainsim where I have also posted this thread. The link is http://forums.uktrainsim.com/viewtopic.php?f=18&t=132408

BFM

From what I can tell in the screenshot you have not placed the component in its own group. From the name you gave the component it appears you want it to be animated. Only groups can be animated.

I know that this is about diesels, but it may help:
http://thegradecrossing.blogspot.com/2012/10/3dc-to-railworks-locomotive-animation.html

Thanks for this reference. It was particularly useful to see how the author placed every object he made in its own group. I was under the delusion that you could not have more than 24 Groups for a successful export to Railworks so I was trying to limit the number of groups to less than that which was why I ended up with such a large number of objects under Maicall yearlohn. Once I placed all these objects in their own group, my problem was solved.

The RW exporter does warn you about being over 24 groups, but that may have been from an earlier time where there was a true restriction. The locomotives I am working on are all over 24 groups.

Glad that tutorial was helpful.

I think you’ll find there is still a limitation – 24 groups at any level in the hierarchy.

So 24 groups can each have 24 sub groups.

However animating subgroups can cause “bumps” in the animations.

I have over 24 groups and things are working fine. What exactly is the limitation? Perhaps its there and I am just not seeing the problem.

You must be logged in to reply in this thread.