Export with transparency

I noticed in a topic about [img:2saovkz2]http://forums.uktrainsim.com/viewtopic.php?f=217andt=78180[/img:2saovkz2]
‘How do i repaint a loco?’

That the window effect looks ok:
[img:2saovkz2]http://i58.photobucket.com/albums/g268/jivebunnystudios/47.jpg[/img:2saovkz2]

Hello,
I am exporting objects from 3DC to Railsimulator without problem. Just I have no transparency in RS.
How to export with transparency ?
Thanks for any help.
<!– s:) –><img src="{SMILIES_PATH}/icon_e_smile.gif" alt=":)" title="Smile" /><!– s:) –>

If you’re talking about transparency for windows, I started to talk about my tests [img:kz7yvt3a]http&#58;//amabilis&#46;com/forumattachments/a/tpc/f/5496093974/m/99810923341?r=71110793341#71110793341[/img:kz7yvt3a]
here
.

What I’ve done is:
I created a 256×256 file for windows. The tga file is created with tgatool2.
Rail Sim keyword for the texture =BlendATexDiff

There is some threshold for which, if the alpha channel is black or too light grey, the result is complete transparency.

There is a remaining problem:
[img:kz7yvt3a]http&#58;//img221&#46;imageshack&#46;us/my&#46;php?image=image4kg0&#46;jpg[/img:kz7yvt3a]
[img:kz7yvt3a]http&#58;//img221&#46;imageshack&#46;us/img221/9953/image4kg0&#46;th&#46;jpg[/img:kz7yvt3a]

I have some unwanted stripes in the alpha channel of the TGPCDX file. The stripes are not in the original TGA file.

Thank you for your answer. I will try it.

Those stripes are due to the DXT3 compression algorithm.

Use RGBA8888 or add a small amount of noise to the alpha channel to remove them. DXT5 would probably be better.

[BLOCKQUOTE class=’ip-ubbcode-quote’][div class=’ip-ubbcode-quote-title’]quote:[/div][div class=’ip-ubbcode-quote-content’]Originally posted by Paul Gausden:
Those stripes are due to the DXT3 compression algorithm.

Use RGBA8888 or add a small amount of noise to the alpha channel to remove them. DXT5 would probably be better. [/div][/BLOCKQUOTE]

RGBA8888 doesn’t mean a lot to me. How would I do this?

Any ideas why, when using a smooth white to black gradient alpha texture, you only get pure transparency or one level of translucency?

Kevin
Kevin

Sorry Kev – If you are using ToAce, use the RGBA 32bit (V2 only) option.

The translucency shown in the sim is down to the shader used – I would experiment with other shaders.
I don’t know about RS or how they have implemented the non-fx shaders, but in FSX(TS2) they have moved entirely over to fx shaders as they are more efficient.

Thanks for the replies Paul.

[BLOCKQUOTE class=’ip-ubbcode-quote’][div class=’ip-ubbcode-quote-title’]quote:[/div][div class=’ip-ubbcode-quote-content’]Originally posted by Paul Gausden:
Those stripes are due to the DXT3 compression algorithm.

Use RGBA8888 or add a small amount of noise to the alpha channel to remove them. DXT5 would probably be better. [/div][/BLOCKQUOTE]

[BLOCKQUOTE class=’ip-ubbcode-quote’][div class=’ip-ubbcode-quote-title’]quote:[/div][div class=’ip-ubbcode-quote-content’]Originally posted by Paul Gausden:
Sorry Kev – If you are using ToAce, use the RGBA 32bit (V2 only) option. [/div][/BLOCKQUOTE]

I’ll check again but I’m sure (after reading a previous post you wrote) I used RGBA 32bit (V2 only) in ToACE. I always use this option in ToACE whatever the texture is (tga, bmp).
So the problem would be that the KRS export tool uses a wrong conversion format from ACE to TGPCDX.

Thank you DOM107 but (sorry) I have
one more question :
You are talking about a ‘Rail Sim keyword for the textures = BlendATexDiff’.

How und where to use that keyword ?
By the blueprint creation ? If yes where ?
Thank for the help. <!– s:) –><img src="{SMILIES_PATH}/icon_e_smile.gif" alt=":)" title="Smile" /><!– s:) –>

[BLOCKQUOTE class=’ip-ubbcode-quote’][div class=’ip-ubbcode-quote-title’]quote:[/div][div class=’ip-ubbcode-quote-content’]Originally posted by Paul Gausden:
Sorry Kev – If you are using ToAce, use the RGBA 32bit (V2 only) option.

The translucency shown in the sim is down to the shader used – I would experiment with other shaders.
I don’t know about RS or how they have implemented the non-fx shaders, but in FSX(TS2) they have moved entirely over to fx shaders as they are more efficient. [/div][/BLOCKQUOTE]

This is the one I use. All the others either give me a uniform red or purple texture!!

I’ve tried some other shaders besides BlendATexDiff but haven’t had any success. Will keep trying. It keeps me occupied for a bit!

Kevin

[BLOCKQUOTE class=’ip-ubbcode-quote’][div class=’ip-ubbcode-quote-title’]quote:[/div][div class=’ip-ubbcode-quote-content’]Originally posted by jjracordon:
Thank you DOM107 but (sorry) I have
one more question :
You are talking about a ‘Rail Sim keyword for the textures = BlendATexDiff’.

How und where to use that keyword ?
By the blueprint creation ? If yes where ?
Thank for the help. <!– s:) –><img src="{SMILIES_PATH}/icon_e_smile.gif" alt=":)" title="Smile" /><!– s:) –> [/div][/BLOCKQUOTE]

You use this in 3DC in the materials palette. Look for the custom fields slot and enter the shader eg BlendATexDiff text entry box and then apply your texture.

If you have already textured your model then right click on the textured part, select properties and enter the shader name into the Railsim text field to the right of the trans setting.

Kevin

[BLOCKQUOTE class=’ip-ubbcode-quote[/img]
[div class=’ip-ubbcode-quote-title[/img]
quote:[/div][div class=’ip-ubbcode-quote-content[/img]
Originally posted by jjracordon:
By the blueprint creation ? If yes where ?
Thank for the help. <!– s:) –><img src="{SMILIES_PATH}/icon_e_smile.gif" alt=":)" title="Smile" /><!– s:) –> [/div][/BLOCKQUOTE]
I use the blueprints from the sample objects found in the Assets part of [img:7samb2kv]http&#58;//www&#46;railsimulator&#46;com/en/downloads/rail-simulator-content[/img:7samb2kv]
<!– m –><a class="postlink" href="http://www.railsimulator.com/en/downloads/rail-simulator-content">http://www.railsimulator.com/en/downloa … or-content</a><!– m –>

I made new tests checking that the TGA file is not compressed.
I used ToAce with the RGBA 32bit (V2 only) option.
Same result (stripes!).

I uploaded, the tga file, the ToACE result and the TgPcDx file [img:q2jp5jw4]http&#58;//dl&#46;free&#46;fr/jScPd54nh/Window&#46;zip[/img:q2jp5jw4]
here
.

Thanks for taking a look at the files.

I should mention that if you are using translucency in your texture, you have to enter ‘Translucency’ in the ‘Tx Alpha’ custom material field. Same goes for transparency… you’ll need to enter ‘Transparency’ in the ‘Tx Alpha’ field. I think I mentioned this as part of the conversion, but it needs to be repeated.

I’ll be adding this bit of information to the FAQ soon.

I used TxAlpha=Translucency with BlendATexDiff.
I also tried Transparency, no changes to the stripes problem.

You must be logged in to reply in this thread.