Alternative Rail Simulator Export

Yes I agree, It just will not work. I have a building that just would not export. well it would but only a few odd polys.
The old exporter worked first time.
This is with the latest 3DC version

Almost there with a new plugin to export IGS files.
If I get a chance to test it tonight I’ll post a beta version without all the extra bells and whistles some time tomorrow.

This will give 3DC users a few extra features:

– View Facing Flora (both types) will work
– Specluar shine effects will work
– Translucency will work and will not hide things
– by default the MIP lod bias for the main texture will be -2, bump maps -1, the rest 0
– shadow objects automatically creased before export

(It also exports at about twice the speed of the current version)

After that I will add extra features to support animated textures and more detailed control over material options. Shader selection (from list) and anything else I can think of.

+ a bit more information on how it all works and what it all means.

Thats great Paul. Looking forward to trying it out.
I used a demo of 3dmax to make some trees for my route but the demo expired and I would like to make some more.

Here it is, along with a bit of extra information in the readme file.

More features will be added in future versions.

I just made a test export of a model that I had previously successfully exported using the old exporter.

I got an error message stating that the object had vertices but no triangles.

Could you try running the Optimize operation on the model and re-exporting?

Does the model contain an empty group?

If that fails I’ll probably need to take a look at the generated IGS file.

Thanks very much Paul. The TrainViewfacingFlora.fx
shader works great

Hi Paul. I did the same experiment as dick8299 and I am afraid with the same results.
When converting to RS file I got the message ‘Geometry with vertices but no triangles’ This is a model converted from TSM into 3DC.

Dick C.

As it turns out, my first attempt was from a converted model also. So I retried the new exporter with a simple model that was an original 3DC model and the export worked.

Thanks Dick. Someone else reported the error went away with an optimize operation.

I still need to check the exporter to make sure it’s 100%.

Do you need any of my files to play with?


Oops forgot to say. I tried the optimise and it still didn’t work.


Thanks for the offer Dick,

If they are not too huge, the IGS file would be a good place to start, the 3DC files are a bonus.

I think you can e-mail me directly through the UKTS forum or the addresses in SFM or shape viewer help file.

Any failed models are always useful.

Are you running asn the administrator when this happens?

I’ll try and make a small setup kit for it tomorrow which should register the dll for you.

One possible reason for the ‘geometry with vertices and no triangles’ message may be the automatic LOD generation removing all small objects from a group.

To text this – try exporting models that error with no LODs.

Also try to reduce the number of groups in a model by moving objects around the hierarchy. There is no real need for lots of groups unless the parts are animated.

You must be logged in to reply in this thread.

108 posts