3DCrafter 10 Preview Available

I’ll definitey add Trim to the list of key operations. I’ll have to think about the others. Invert and Flip seem more secondary to me. Ops you would use just now and again (correct me if I’m wrong). There are a few that are not super critical on the “key” list, but that is because the drop down list of ops is not available to the freeware version, and those ops need to be available to everone.

You’ll laugh… the only reason it is now “erase” instead of “delete” is that I had a better icon for “erase”. 🙂

Just a couple of quick observations. No problems installing this version. However, it doesn’t remember window state when I exit the program. I always maximize the screen, but it doesn’t open maximized the next time I start it. Also, the recent files pane (next to the Open button) remains empty, even though I’m opening and closing files, exiting out, and restarting again.

I was able to open and work on a railroad truck (bogie) model that was created in 9.3. No problems or crashes experienced. One problem that I have in 9.3 continues in this version… and that is with dividing a face. I’ll select a face and divide (either using right click or the divide toolbar button), and after I click out of the object, I’m unable to click back into it. I can click the object immediately behind it, but not the object I was working on. My work around is the save the file, exit 3DCrafter, restart and reopen the file. I can then select the object again. In 9.3, if I click on the object in the object hierarchy, I get a graphics error message, and the program aborts.

I am using a block painted with a drawing as a background, and the object I’m working on is either immediately in front of it, or slight recessed into it. If you’d like, I can email you the file. It’s still fairly small.

Overall though, I like it. I was able continue working on the file without too much difficulty. It will take a little time to get use to the interface, and I haven’t even tried the UV mapping yet (I’ve always struggled with this).

Howard

I don’t use the trim command very often, as it seems to leave the odd artefact in models. Usually I just highlight point, line or face and press delete key. That seems to leave a much cleaner mesh for me.
Ops I use the most are Optimize shape (use it all the time when applying textures), divide, doubleside( PG plugin), chamfer, extrude, flip, mirror, solidify, scale, shift, apply material and UV Re Map. Plugins I use the most are usually Crease All, Create unique names and the Material manager.

Just noticed since applying Pauls plugins to V10, I seem to have lost them in V9.3. I’ll try reinstalling them.

Other will probably have differing preferences. Hope the above helps.

There is a problem with Pauls plugins for v9.3 after installing the V10 ones. Left a note in “Plugins Operations and Scripts for 9.3”

I just updated the plugin installer so it shouldn’t clash with the 9.3 plugins any more.

Sorry Paul. V10 still removes the V9.3 plugins. 9.3 installer still reports newer version installed and finishes. Tried deleting everything and reinstalling but still get the same result.

Strange. Installing the V10 plug-ins had no effect on the v9.3 plugins in my installation. They are all still there and are working normally.

BFM

I hope nobody takes this the wrong way, but I’m really happy to see that I’m not the ony one having installer problems. 🙂

Hi Jim,

I can only suggest uninstalling all plugins, re-downloading the latest version of both, then re-installing.

http://www.gausdens.talktalk.net/3dcplugins9.3.zip
http://www.gausdens.talktalk.net/3dcplugins10.zip

I’m pretty sure they shouldn’t clash now, I just forgot to change the GUID going from 9.3 to 10 so it thought they were the same product. The latest version is correct.

Cheers,
Paul

  • This reply was modified 1 year, 9 months ago by  PaulGausden.

There does still seem to be a conflict between the two sets of plugins. I noticed when installing the V.10 plugins in my pc, it first de-registers modules from the 9.3 version. If I try to re-install the V.9.3 plugins after installing the V.10 ones, a message appears that there is a more up to date version already installed and the installation program finishes. Among the plugins and operations that have disappeared from v.9.3 is the double side operation.

BFM

Well a day of disaster for me. Win 10 did an update this morning (Cumulative Update for Windows 10 Version 1511 for x64-based Systems (KB3116900) ) plus a security update for IE Flash player. Since then Crafter 9.3 crashes as soon as the load window pops up. Tried the usual roll backs and system restores, but nothing works. In the end in desperation, I did a complete re-install of Win 10 without letting it update. Reinstalled Crafter 9.3 and it still crashes at the same point. Installed Crafter version 10 and that runs OK. Loaded a model in but as soon as I try to export using Train Sim IGS or AI exporters it crashes as soon as the exporter starts. Same result with the Railworks exporter.

  • This reply was modified 1 year, 9 months ago by  JimCrow.

Sorry to hear that Jim. I’ll install the Windows 10 update today and see what I get.

Does it make any difference to run as administrator?

Yes tried running as administrator, no effect. Ran compatability troubleshooter too but to no effect. Tried everything to get it to run but still get the same crash as soon as the 3d Crafter program loading screen appears. Might be due to the updates, or maybe the problems with Pauls plugins. Don’t think it’s that though. If the Trainsimulator exporters worked in V10 I could manage.

I just ran the latest link for the v10 scripts and I noticed it was installing to C:\Program Files (x86)\3DCrafter 9 by default instead of 10. Could this be the problem?

@richard, I found a reproducible crash. If I open the options dialog and walk through the tabs a couple time it will throw a blank modal dialog up and crash. I ran into this because I was looking for the check box to Enable Trainworks Features which does seem to be there anymore.

Also I am able to reproduce the other problem I was refering to with opening an old v9 model in v10. In this case the model has two components each using their own primary texture image. In v9 it looks fine. In v10 the one of the primary textures is not showing. I will send you an email shortly.

  • This reply was modified 1 year, 9 months ago by  PapaXpress.

You must be logged in to reply in this thread.