3DCrafter 10 Beta 1 Available

v10 Beta 1 is now available.

IMPORTANT: If you installed Alpha 1 or Alpha 2, you will have uninstall it, and also the 3DCrafter Prerequisites (there may be more than one).
AND, you’ll need to re-register. Sorry!

Download 3DCrafter 10 Beta 1

With version 10, 3DCrafter now has a “ribbon” interface. You might know it from Microsoft Office, WordPad, Paint and others. I won’t try to explain it. I hope everyone has used it at some point. One of the benefits of this interface, and the reason I decided to use it, is context specific tabs that show only functions related to your current selection. I think this works particularly well with 3DCrafter.

IMPORTANT: This version is feature complete, but there are still many features that need refining, and there may be some that simply do not work, or don’t work as expected.

What’s new
========

o) I have organized the main toolbar, the “ribbon” by modelling phase: “Build”, “Paint”, “Layout” and “Animate”. Each of these phases has a toolset associated with it. There’s a toolset button on the left side of the ribbon.

o) There are three user modes available: “Novice”, “Intermediate” and “Expert”. These are available on the “Options” tab. Novice is really just for beginners. It hides many features so that beginners are not overwhelmed. I expect most people will want to use Intermediate, which has all features enabled. Expert is for those who want to work more like 3DCrafter version 9. It combines the Build, Paint and Layout phases into one. Unfortunately this results in a crowded toolset, but I’ll be working to improve that.

o) The Navigation Controls is gone. Gone forever. It was more trouble than it was worth. People tended to get lost, get things turned upside down etc. It has been replaced by “Orbit”, “Pan”, and “Zoom”. These are on the main toolbar, but they can also be accesssed via the center mouse wheel/button. Orbit is the center button, Pan is the shift key held down with the center mouse button, and Zoom is the scroll wheel.

o) The Edit Control is now “compact”. It is basically the same thing, but making it “compact” makes the various surfaces easier to click on because I can orient things more suitably. The one thing you’ll notice is that the vertical scale/move are gone. But, all you have to do is right-click on the surfaces to get vertical scale/move. Just like if you were clicking on an object to move it up and down. I want to get rid of the Edit Control completely at some point, but there are really too many things to do, and I want to put out something as a starting point.

o) The biggest new “feature” is the ability to draw primitives. How it works:

-pick a primitive,
-click to start, drag, (use the scroll wheel to get the detail level you want)
-click to indicate the size you want
-drag again for height (use the scroll wheel to get the vertical detail level you want)
-click to finish

o) with v10 context is everything. You should only get functions that are related to the modelling phase you are in, and what (if anything) you have selected. This will have to be progressively refined through the alpha/beta period.

o) One of the goals is to make it so that normal modelling tasks can be completed without ANY toolbars, panels etc visible, AND without having to remember any complicated key-combinations. I’m still working on this one, but it’s coming along. The key is that the ribbon can be minimized and important tools and operations can be placed in an are called the “Quick Access Toolbar”. I’m going to need help in choosing the standard tools and operations to add to it. Select, Select Point/Edge/Face, and Extrude are obvious ones I’d say. But there are certainly others.

o) The panels that normally were located along the left side now have to be shown using the View tab. Only those panels that are relevant to the toolset you are using are available. During modelling I don’t think any of them need to be displayed normally. Just every once in a while. I imagine it like this: model… model… model… need to look at the layers – show the panel – do something with layers – hide it … model… model… model… need an oddball operation not on a context tab-show the panel use the operation-close it… model… model… model…. When in Paint mode I kind of think it is the same. You choose a material, and then close up the material panel. But that might not always be the case.

o) The settings for an operation (if any) are immediately shown after you apply it to a selection because this is typically when you need them. I’ve tried to make it so that it doesn’t get in the way, but sometimes it does. It isn’t moveable, or closeable. I’d rather it not be. My experience with closing these tool settings is that they always seem to be gone when you need them-and operations almost always need some adjustment to settings. My experience with moving them is that they just end up in the way again in a couple of minutes, so they are constantly being moved and in the way. The way I have done it they are consistent, and it really isn’t that hard to ctrl-center click to pan the scene if something is obscured. That’s just my opinion of course, not everyone is going to agree.

o) The “Info” panel on the right is now context specific also. I “hope” it can always be closed during modelling unless doing a tutorial. I’ll need feedback on this. The panel can be closed either by clicking on the divider, or dragging it to the right. It can be re-opened by clicking on the divider or dragging it to the left.

o) There is a simple “material palette” on the paint/expert toolsets.

To do
====
o) Icons need to be completed
o) The expert build toolset is really crowded. I don’t know what I’ll do about that yet. Probably I will buttons auto-size small on some monitors so it fits in.
o) Many functions are there just as buttons and don’t do anything.
o) The right-click menu only sort of works, and hasn’t been modified for the new context based interface. I may move some of the features to the ribbon. I haven’t decided for certain.
o) A couple of tutorials need to be entirely re-written, and many others need adaptation. Many screen shots need updating. I’m leaving that to the very end. I want ot be 100% certain the interface won’t change. It’s a big job and I don’t want to do it twice.

What’s coming
===========

o) along with the simplified material palette, I’m going to make the “fill” tool apply using a kind of “automated unwrap” based on the auto-unwrap plug-in. It’s not perfect, but for simple models it works pretty well when combined with the paint tool. Of course more advanced material application is still possible via various operations. Actually… I’m still working on how I’ll be doing this.

Feedback is much appreciated. Rather than reporting minor bugs, at this point I’d like to know about bugs that cause crashes, features that simply don’t work, and ideas on improving the interface.

I’m starting to dislike the automatic login with no logout option.

I couldn’t remember my login so I added another one, now it won’t let me log out and my licence code doesn’t work :(

Perhaps logging in should not be mandatory.

I also have problems. The system did not recognise the account I created to install alpha 1. I had to create a new account, using the same e-mail address and password as I created for the alpha version, to launch the program. The program then launched, but when I try to enter the key code, I received a message that ‘ the account server is unavailable’. I decided to close the program and try again.

The installation did not create a desktop or start menu item so I had to go searching for the ‘exe’ file and after a lot of searching, eventually located it under ‘users/…/AppData\Local\Apps\2.0\2WBLY5VA.GMH\5OK78P1J.KZ3\3dc…tion_f9a274bfc302d1e2_000a.0000_a20e2188f161e17c’ .

I tried launching the program from the ‘exe’ file. Once again, I was asked to create an account as my existing sign-in was not recognised. I again created a new account using the same credentials as for the previous version and the launch process commenced. But launching stalled at the initialising phase with a message ‘unhandled exception’ and I had to close the program with Task manager.

I will try again later to-day to uninstall and re-install the program to see if that makes any difference,

BFM

Well, v10 is certainly coming along nicely now. Installed / running fine for me, good to see Povray working again already.

As has been mentioned elsewhere I think, the shape operation table looks a bit cramped compared to the rest of the uncluttered interface.

I don’t know what the ‘relax’ option will do when it is implemented.

I must remember to use the erase button rather than just pressing delete when I want to get rid of a shape, v10 doesn’t seem to like this.

Looking forward to the lights options and raytraced textures coming back. Visible light source would be a bonus.

Oh, and I agree with Paul that having to be online to run v10 could be a nuisance at times.

Paul

PS.

I managed eventually by closing and re-booting to launch the program. This time, it recognised my account. But entering the key code received resulted in the message ‘The license code entered is not valid’.

It’s becoming a bit frustrating.

BFM

Ok, that isn’t good to hear. I imagined it like this: create account, never login again.

I definitely didn’t expect so many difficulties from the account creation. But maybe it is because of the new server version I installed last night, and having to recreate accounts etc.

I’ll work on the login aspects today. I didn’t really want to make it a priority, but it looks like I’ll have to.

Also, I need to fix some problems with the installer it seems.

So, there’s another way that I can do this that will give me what I need but doesn’t require login. It will take me a day or two to write I think. So, for beta 2.

Thanks for your patience!

Ok, a version is available. It’s going to look very familiar. :-)

And the install went quite smoothly on my test machine that had Beta 1 installed already.

Oh – I was using it at the time, restarted 3DC and it said update available :), all installed OK, but did crash on exit.

A couple of comments:

I selected a face, then had to switch back to the Home tab to run a script – might need scripts and plugins on selection contexts.

I use extrude shapes fairly often and there are a few bugs, some were there in 3DC9
Can’t zoom on some views, can’t fix a point with double click and can’t join the last to first point to make a solid object.

Cheers,
Paul

Yes, scripts are still an issue. I think you may be right on that one. To repeat them.

Plug-ins aren’t 100% properly sorting yet. Actually quite a few are wrong. But I’ll fix ’em.

I’ll have a look at the extrude issues.

One thing I’m wondering about is if there are any operations missing from the context tabs that are important. And are any there that you think shouldn’t be there.

All seems to be working correctly at the moment…(installation and launch)

  • This reply was modified 1 year, 6 months ago by  robix61.

Oh good. Hopefully I can keep it that way!

I suspect that my problem happened because my uninstaller did not completely uninstall the previous version. I found a whole folder of files dated 7/11 which belonged to the alpha1 version. After deleting these files and reinstalling the beta 1, the program launched correctly and accepted my key code.

I tried a few simple operations and these went smoothly. But when, as I continued experimenting, I loaded a current project (a Cab for Train Simulator), the program very quickly froze after a few operations- even more rapidly than with 9.3.3 and I had to use Task Manager to exit. One operation that I find very important seems to have gone awol – the Double Side operation. It was in 9.3.3. I also had a problem with the UV Unwrap which does not seem to be working.

BFM

Like others, even after a normal exit, I am receiving a program crash message and when I re-launch, the option to recover unsaved work appears.

BFM

Thanks BFM. Maybe I ought to have that model (and textures) that is failing on you. And if you can tell me how to reproduce it, that’d be awesome. “assistance at amabilis.com”.

Weird that the exit never fails for me on my computers. Maybe I don’t do enough modelling before exiting.

Cannot locate the 3DCrafter.exe to start the program and make a shortcut. Clicking on Setup.exe does start the program but this seems rather roundabout. Windows search did not find 3DCrafter.exe for 10 Beta nor did I find it going through every 3DC 10 Beta folder. Since others are running the program, what am I missing ?

Mike

The thread ‘3DCrafter 10 Beta 1 Available’ is closed to new replies.

Announcement
47 posts Thread is closed for discussion
recent posts