3DCrafter 10.1 Alpha 1 Available

10.1 should run on Windows 7 without a rebuild. It did last time I tried it. I am only supporting Windows 10 officially because I have no Windows 7 machines left. All of my test machines (I have 4) are on Windows 10.

Richard,
I upgraded from Windows 7.

Hi Richard,

I’ll give it a try then. Are there any issues you are aware of with having 10.1 and 9.3.1649 coexist on the same machine? I just got 9.3 installed and working again after a hard drive failure. Thanks!

Howard

Since installing and finding problems with V10 Alpha 1 and having to uninstall it, I cannot now get Paul Gausdens plugins to show in V9.3 with the 3dcplugins9.3.1649 set. Been through the registry removing all references to V10. I even uninstalled V9.3 and cleaned the registry before installing everything again. Still no joy. Looks as if a Windows 10 reinstall is now the only option. Be warned.

Jim – Keep searching / removing registry entries. Try searching for 3dc instead of 3dcrafter, and also search for 9.3. The more open the search patterns are, the more results you’ll get.

I had a similar problem when after uninstalling v10 and reinstalling v9.3 on Win7, I couldn’t install Paul’s v9.3 plugins. I kept getting a message saying a newer version was already installed. The fix finally happened after uninstalling 9.3 and spending hours going through the registry removing orphaned entries, I was finding entries going back to v7, and I hadn’t had v7 installed for years.

Still no joy with installing 3dcplugins9.3.1649 . Did a Windows 10 reset removing all apps/progs and then installed V9.3 followed by the plugins. Still not showing in the program. In desperation I did a complete Windows 10 install after formatting the drive. Even after that the plugins still refuse to show. Crafter is almost useless to me without the doubleside op.

Just realised the version of Crafter 9.3 in the downloads is 1920. I’ve been installing V1649 of the plugins. Just found Crafter V1949 on the forum and installed it. All now working. Sheesh! Note to self and everyone else. Check program and plugins are same version.

3DC 10 is built with Windows Forms, a technology that has existed for more than a decade. But that’s only the user interface; most operations still invoke the old Core via a COM interface, so the “beef” of the software is most likely the same C++ codebase it has always been. This means that the entire technology stack used in 3DC 10 is fully compatible with prior Windows versions and Windows 10 is thus not “required”.

Generally speaking, in software development Windows 10 is only required when the application is using the new Windows platform API. In practise, such app is built using the new UWP tehcnology, which enables the app to run also on devices other than a Desktop computer. This is not the case with 3DC 10, and based on my own experiments, it would not be ideal to build a 3D modeling app such as 3DC, using UWP. Not without a complete re-design of both UI and concepts anyway.

The Click-Once deployement is also “old” technology. Deploying to a Windows 7 or Windows 10 machine should essentially work the same way. The main difference to the standard MSI install would be the installation location, which is specific to the user (under AppData). A Click-Once app is isolated in nature and each update is basically put into its own folder. That being said, compatibility issues between 3DC 9.x and 10.x probably have something to do with Windows registry keys.

*** Please don’t reset your Windows 10 installation because of a software misconfiguration. You shouldn’t have to. It’s the developer’s responsibility to eliminate these kind of issues ***

Usually Click-Once deployment is used for software if it must support non-Admin installation (all Click-Once apps run in user mode priviledges). Such applications thus never install/register components, or do anything that would require Admin priviledges in general. Then in the other hand, Click-Once comes with an in-built upgrading functionality, which understandably is handy in Alpha/Beta stage.

  • This reply was modified 6 months, 2 weeks ago by  Zero.

Hi
I have managed to get the Alpha installed and up and running.
However, once I exit the program and try to restart, then the panels open but then I get a “3DCrafter has stopped working” message and it just all closes down.

While it was running, I did notice that I could not change the views using the small “cog wheel” in the top RH panel.
And when selecting multiple views from the ribbon, the grid did not show in the second window and could not change because of the problem above.

The thread ‘3DCrafter 10.1 Alpha 1 Available’ is closed to new replies.

Announcement
24 posts Thread is closed for discussion