Track incomplete now. Why?

Thank you for that Paul. That will be helpful but I’ll tell you one function that would have been useful then and I’ve wished for many a time is a variation on the Equalize Points operation where I could specify what value I’d like the point to equalize on. In this case it would have been useful to select all the points at either end of the loft and equalize them to Z = 0 at the one end and then Z = 4 at the other end.

While I was attempting to change the texture on my rail section I had this problem occur. I swapped one texture for another one (in this case a .bmp for a .tga otherwise virtually identically named) and reexported it. Now I can only get the track section to export as below with one side of the ballast missing or invisible. I’ve tried to doubleside it in the suspicion that I might have a flipped normal or something like but I still get the same result. Does anyone have a way to fix this? I’m back at the hair pulling stage.


Oh and by the way, I have used both textures since to no avail so I don’t believe it’s in the textures. I’ve even compared it to other successful track sections and made the hierarchies the same but with the same result.

Hello Bill

Not sure if this is going to help, but on the UKTS forum you say that you use LoftTexDiff.fx as shader.
If you use a .tga texture with alpha channel now, you should use LoftTexDiffTrans.fx as shader.

Also you could check the mapping of the texture with the UV-Remap operation .

Hope this helps


Well, I tried it with LoftTexDiffTrans.fx but the result was the same. I simply don’t know enough about how these files are constructed to know why these surfaces are failing to appear. I don’t know if there’s a problem with the model, the way it’s created, the way it’s textured, the way it’s exported (I’ve used both exporters with the same result). I’ve deleted all old files and reexported – no luck. I suspect the files are getting corrupted somewhere but I have no idea where or how.

Hello Bill

I have made a few tracks with success

Can you send the .3DC file and the texture over , I will have a look at it.

My e-mail is in my profile .



I think I finally found the problem and it’s so simple I want to scream in frustration. It’s doubly annoying in that I knew of the problem and had simply forgotten it. Partially it was carelessness on my part and partly a quibble I have with 3DC and the relative ease of moving a point just a teeny bit even when you don’t intend, need or indeed want it to move.
So, just to remind everyone and we should all write it 100 times, Track is 4 meters long and starts at 0 meters – not 3.999m not 4.002m not at 0.001m or -0.001m. As soon as I had corrected every and I do mean EVERY pertinent point, my track magically reappeared.

Live and learn.

And by the way – many thanks to HondaWizard for his help. It’s nice that people are willing to lend a hand.

Well spotted – I may write a small script that will check all points on a loft object to make sure they’re 0

Here ’tis

Select an object, run the script.

Points where Z andlt;andgt; 0 are displayed.

(Right Click on link, Save As, into the 3DC Scripts foler)

You must be logged in to reply in this thread.

8 posts
recent posts